import re
regex = re.compile(r"^([^\\\n]*(?:\\\\)*)\*", flags=re.MULTILINE)
test_str = ("*\n"
"\\*\n"
"\\\\*\n"
"\\\\\\*\n"
"\\\\\\\\*")
subst = "$1%"
result = regex.sub(subst, test_str)
if result:
print(result)