#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ",(?![^()]*\))\s*"
Local $sString = "abc, 3rncd (23uh, sdfuh), 32h(q23q)89 (as), dwe8h, edt (1,wer,345,rtz,tr t), nope"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)