const regex = /,(?![^()]*\))\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?![^()]*\\))\\s*', 'g')
const str = `abc, 3rncd (23uh, sdfuh), 32h(q23q)89 (as), dwe8h, edt (1,wer,345,rtz,tr t), nope`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);