$re = '/,(?![^()]*\))\s*/';
$str = 'abc, 3rncd (23uh, sdfuh), 32h(q23q)89 (as), dwe8h, edt (1,wer,345,rtz,tr t), nope';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;