using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img(?!\sdata-src=([\'\""])([^>]*?)[\S\h\v]*?\2)\ssrc=([\'\""])([\S\h\v]*?)\3";
string input = @"<img src=""test'""/> # this should be matched, and it is
<img data-src=""abc"" src=""abc""/> # this one shouldn't be matched, but it is";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}