$re = '/<img(?!\sdata-src=([\'\"])([^>]*?)[\S\h\v]*?\2)\ssrc=([\'\"])([\S\h\v]*?)\3/im';
$str = '<img src="test\'"/> # this should be matched, and it is
<img data-src="abc" src="abc"/> # this one shouldn\'t be matched, but it is';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);