re = /<img(?!\sdata-src=([\'\"])([^>]*?)[\S\h\v]*?\2)\ssrc=([\'\"])([\S\h\v]*?)\3/im
str = '<img src="test\'"/> # this should be matched, and it is
<img data-src="abc" src="abc"/> # this one shouldn\'t be matched, but it is'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end