use strict;
my $str = 'T&&T&T';
my $regex = qr/(?=\w|(?<!&)&)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";