import Foundation
let pattern = #"(?=\w|(?<!&)&)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"T&&T&T"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)