import re
regex = re.compile(r"\b(?!.{0,7}[DFIOQU])[A-VXY]\d[A-Z][^-\w\d]\d[A-Z]\d\b", flags=re.MULTILINE)
test_str = ("Valid\n"
"123 4th Street, Toronto, Ontario, M1A 1A1\n"
"12456 Pine Way, Montreal, Quebec H9Z 9Z9\n"
"Invalid\n"
"123 4th Street, Toronto, Ontario, Q1A 1A1\n"
"12456 Pine Way, Montreal, Quebec H9Z-9Z9\n"
"56 Winding Way, Thunder Bay, Ontario, D56 4A3\n"
"34 Cliff Drive, Bishop's Falls, Newfoundland B7E 4T\n"
"123 4th Street, Toronto, Ontario, M1A 1Q1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")