re = /\b(?!.{0,7}[DFIOQU])[A-VXY]\d[A-Z][^-\w\d]\d[A-Z]\d\b/m
str = 'Valid
123 4th Street, Toronto, Ontario, M1A 1A1
12456 Pine Way, Montreal, Quebec H9Z 9Z9
Invalid
123 4th Street, Toronto, Ontario, Q1A 1A1
12456 Pine Way, Montreal, Quebec H9Z-9Z9
56 Winding Way, Thunder Bay, Ontario, D56 4A3
34 Cliff Drive, Bishop\'s Falls, Newfoundland B7E 4T
123 4th Street, Toronto, Ontario, M1A 1Q1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end