#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!barna).(?!erne).(?!ene).(?!en).. (?:sin|vår)e?(?:$| (?!egen|egne))"
Local $sString = "" & @CRLF & _
"WRONG:" & @CRLF & _
"påvirke sin katt" & @CRLF & _
"påvirke sine omgivelser" & @CRLF & _
"Vent litt mens våre nettsystemer validerer eksamenen." & @CRLF & _
"sikkerheten til sine barn på skolen" & @CRLF & _
"" & @CRLF & _
"CORRECT:" & @CRLF & _
"påvirke katten sin" & @CRLF & _
"påvirke omgivelsene sine" & @CRLF & _
"Vent litt mens nettsystemene våre validerer eksamenen." & @CRLF & _
"sikkerheten til barna sine på skolen" & @CRLF & _
"" & @CRLF & _
"lage sine egne kart og virtuelle turer"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")