import Foundation
let pattern = #"(?!barna).(?!erne).(?!ene).(?!en).. (?:sin|vår)e?(?:$| (?!egen|egne))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
WRONG:
påvirke sin katt
påvirke sine omgivelser
Vent litt mens våre nettsystemer validerer eksamenen.
sikkerheten til sine barn på skolen
CORRECT:
påvirke katten sin
påvirke omgivelsene sine
Vent litt mens nettsystemene våre validerer eksamenen.
sikkerheten til barna sine på skolen
lage sine egne kart og virtuelle turer
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)