use strict;
my $str = '
WRONG:
påvirke sin katt
påvirke sine omgivelser
Vent litt mens våre nettsystemer validerer eksamenen.
sikkerheten til sine barn på skolen
CORRECT:
påvirke katten sin
påvirke omgivelsene sine
Vent litt mens nettsystemene våre validerer eksamenen.
sikkerheten til barna sine på skolen
lage sine egne kart og virtuelle turer';
my $regex = qr/(?!barna).(?!erne).(?!ene).(?!en).. (?:sin|vår)e?(?:$| (?!egen|egne))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}