#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=_)\d+(?=\.\w+$)"
Local $sString = "asdfasd_400.mp4" & @CRLF & _
"asdfasd_600.mp3" & @CRLF & _
"asdfasd_1000.mxf" & @CRLF & _
"BLIVE_CEOFoC_210720_1245_400.mp4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")