const regex = /(?<=_)\d+(?=\.\w+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=_)\\d+(?=\\.\\w+$)', 'gm')
const str = `asdfasd_400.mp4
asdfasd_600.mp3
asdfasd_1000.mxf
BLIVE_CEOFoC_210720_1245_400.mp4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}