$re = '/(?<=_)\d+(?=\.\w+$)/m';
$str = 'asdfasd_400.mp4
asdfasd_600.mp3
asdfasd_1000.mxf
BLIVE_CEOFoC_210720_1245_400.mp4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);