#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".+?:\/\/.+?(\/.+?)(?:#|\?(.*)|$)"
Local $sString = "http://ci-runner-3.owlsrv.de:10000/wp-admin/admin.php?page=real-cookie-banner-component#/scanner"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")