package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.+?:\/\/.+?(\/.+?)(?:#|\?(.*)|$)`)
var str = `http://ci-runner-3.owlsrv.de:10000/wp-admin/admin.php?page=real-cookie-banner-component#/scanner`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}