$re = '/.+?:\/\/.+?(\/.+?)(?:#|\?(.*)|$)/';
$str = 'http://ci-runner-3.owlsrv.de:10000/wp-admin/admin.php?page=real-cookie-banner-component#/scanner';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);