import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:Fwd|R[eE]):)+\\s*";
final String string = "Fwd: Please look at the attached documents and take action \n"
+ "NSN for the ones who care\n"
+ "News for all team members \n"
+ "Fwd:RE:Re: Please take action on the action needed items \n"
+ "Fix all the mistakes please \n"
+ "Fwd:Re: Take action on the attachments in this email \n"
+ "Fwd:RE: Action is required ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}