const regex = new RegExp('^(?:(?:Fwd|R[eE]):)+\\s*', 'gm')
const str = `Fwd: Please look at the attached documents and take action
NSN for the ones who care
News for all team members
Fwd:RE:Re: Please take action on the action needed items
Fix all the mistakes please
Fwd:Re: Take action on the attachments in this email
Fwd:RE: Action is required `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);