import re
regex = re.compile(r"^(?:(?:Fwd|R[eE]):)+\s*", flags=re.MULTILINE)
test_str = ("Fwd: Please look at the attached documents and take action \n"
"NSN for the ones who care\n"
"News for all team members \n"
"Fwd:RE:Re: Please take action on the action needed items \n"
"Fix all the mistakes please \n"
"Fwd:Re: Take action on the attachments in this email \n"
"Fwd:RE: Action is required ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)