$re = '@([a-zA-Z0-9,\(\)\-\s\.\#:/]*)Date From: [0-9]{2}/[0-9]{2}/[0-9]{4}([, \s]*[0-9]{2}/[0-9]{2}/[0-9]{4})*\s(Division Type: [A-Z ]*)*@m';
$str = 'BBB 2324 WRETY RTJE, II 1111 (000) 000-0000 Date From: 01/01/2011, 01/11/2011 AAAAA / AAAA 111 AAAA AA AAAAAA, AA 11111-1111 (111) 111-1111 Date From: 01/11/2012 ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);