import re
regex = re.compile(r"([a-zA-Z0-9,\(\)\-\s\.\#:/]*)Date From: [0-9]{2}/[0-9]{2}/[0-9]{4}([, \s]*[0-9]{2}/[0-9]{2}/[0-9]{4})*\s(Division Type: [A-Z ]*)*", flags=re.MULTILINE)
test_str = "BBB 2324 WRETY RTJE, II 1111 (000) 000-0000 Date From: 01/01/2011, 01/11/2011 AAAAA / AAAA 111 AAAA AA AAAAAA, AA 11111-1111 (111) 111-1111 Date From: 01/11/2012 "
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")