// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z0-9,\(\)\-\s\.\#:/]*)Date From: [0-9]{2}/[0-9]{2}/[0-9]{4}([, \s]*[0-9]{2}/[0-9]{2}/[0-9]{4})*\s(Division Type: [A-Z ]*)*").unwrap();
let string = "BBB 2324 WRETY RTJE, II 1111 (000) 000-0000 Date From: 01/01/2011, 01/11/2011 AAAAA / AAAA 111 AAAA AA AAAAAA, AA 11111-1111 (111) 111-1111 Date From: 01/11/2012 ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}