import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<time>\\d{4}-\\d{1,2}-\\d{1,2} \\d{1,2}:\\d{1,2}:\\d{1,2}.\\d{3})\\s+(?<level>[^\\s]+)\\s+(?<pid>\\d+).*?\\[\\s+(?<thread>.*)\\]\\s+(?<class>.*)\\s+:\\s+(?<message>.*)";
final String string = "2016-01-11 16:14:32.474 INFO 1 --- [ main] fluentd.FluentdBootApplication : Starting FluentdBootApplication on 750117306ae6 with PID 1 (/app.jar started by root in /)\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}