import Foundation
let pattern = #"^(?<time>\d{4}-\d{1,2}-\d{1,2} \d{1,2}:\d{1,2}:\d{1,2}.\d{3})\s+(?<level>[^\s]+)\s+(?<pid>\d+).*?\[\s+(?<thread>.*)\]\s+(?<class>.*)\s+:\s+(?<message>.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2016-01-11 16:14:32.474 INFO 1 --- [ main] fluentd.FluentdBootApplication : Starting FluentdBootApplication on 750117306ae6 with PID 1 (/app.jar started by root in /)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}