$re = '/(?<![\p{L}0-9_])#([\p{L}0-9_]+)/ui';
$str = '#hash //works
#hash_hash //works
#hash_não // get just $hash_n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);