re = /(?<![\p{L}0-9_])#([\p{L}0-9_]+)/i
str = '#hash //works
#hash_hash //works
#hash_não // get just $hash_n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end