import re
regex = re.compile(r"(?<![\p{L}0-9_])#([\p{L}0-9_]+)", flags=re.UNICODE | re.IGNORECASE)
test_str = ("#hash //works\n"
"#hash_hash //works\n"
"#hash_não // get just $hash_n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")