using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\(]+)\s+\(([^\)]+)\)\s+\(([^\)]+)\)";
string input = @"Half Day Morning (9:00 AM - 11:30 AM) (M/T/W/TH/F)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}