$re = '/([^\(]+)\s+\(([^\)]+)\)\s+\(([^\)]+)\)/m';
$str = 'Half Day Morning (9:00 AM - 11:30 AM) (M/T/W/TH/F)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);