// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\(]+)\s+\(([^\)]+)\)\s+\(([^\)]+)\)").unwrap();
let string = "Half Day Morning (9:00 AM - 11:30 AM) (M/T/W/TH/F)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}