using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\(\+\))(\w+)\.[^=]+=\s*(?:(\w+)\.)?.*$";
string input = @"a.deptno = b.dept_no(+)
c.deptno(+)=b.dept_no
a.deptno(+)= 900
a.deptno = b.dept_no
c.deptno=b.dept_no
a.deptno= 900
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}