$re = '/^(?=.*\(\+\))(\w+)\.[^=]+=\s*(?:(\w+)\.)?.*$/m';
$str = 'a.deptno = b.dept_no(+)
c.deptno(+)=b.dept_no
a.deptno(+)= 900
a.deptno = b.dept_no
c.deptno=b.dept_no
a.deptno= 900
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);