re = /^(?=.*\(\+\))(\w+)\.[^=]+=\s*(?:(\w+)\.)?.*$/m
str = 'a.deptno = b.dept_no(+)
c.deptno(+)=b.dept_no
a.deptno(+)= 900
a.deptno = b.dept_no
c.deptno=b.dept_no
a.deptno= 900
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end