#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?),"(.*?)",(.*?)$"
Local $sString = "18.10.2015,"Math",http: //address.html" & @CRLF & _
"" & @CRLF & _
"17.10.2015,"English",http: //address.html" & @CRLF & _
"" & @CRLF & _
"18.10.2015,"English",http: //address.html" & @CRLF & _
"" & @CRLF & _
"19.10.2015,"Science",http: //address.html" & @CRLF & _
"" & @CRLF & _
"17.10.2015,"Math",http: //address.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")