using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?),""(.*?)"",(.*?)$";
string input = @"18.10.2015,""Math"",http: //address.html
17.10.2015,""English"",http: //address.html
18.10.2015,""English"",http: //address.html
19.10.2015,""Science"",http: //address.html
17.10.2015,""Math"",http: //address.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}