import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?),\"(.*?)\",(.*?)$";
final String string = "18.10.2015,\"Math\",http: //address.html\n\n"
+ "17.10.2015,\"English\",http: //address.html\n\n"
+ "18.10.2015,\"English\",http: //address.html\n\n"
+ "19.10.2015,\"Science\",http: //address.html\n\n"
+ "17.10.2015,\"Math\",http: //address.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}