const regex = /\btext \(jadad\)\b/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\btext \\(jadad\\)\\b', 'mgi')
const str = `lipsum is a dummy text (jadad) alsdasldk.
lipsum is a dummy text (jadad).
lipsum is a dummy text (jadad)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}