// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\btext \(jadad\)\b").unwrap();
let string = "lipsum is a dummy text (jadad) alsdasldk.
lipsum is a dummy text (jadad).
lipsum is a dummy text (jadad)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}