$re = '/\btext \(jadad\)\b/mi';
$str = 'lipsum is a dummy text (jadad) alsdasldk.
lipsum is a dummy text (jadad).
lipsum is a dummy text (jadad)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);