#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:\b|\.|\s|\!|\?|\n|^)text \(jadad\)(?:\b|\.|\s|\!|\?|\n|$)"
Local $sString = "lipsum is a dummy text (jadad) alsdasldk. // match" & @CRLF & _
"lipsum is a dummy text (jadad). // match" & @CRLF & _
"lipsum is a dummy text (jadad) // match" & @CRLF & _
"lipsum is a dummy (text (jadad)) // match" & @CRLF & _
"" & @CRLF & _
"lipsum is a dummy text (jadad // should not match" & @CRLF & _
"lipsum is a dummy text jadad) // should not match" & @CRLF & _
"lipsum is a dummy text (jadad)asd // should not match" & @CRLF & _
"lipsum is a dummy ()text (jadad)asdasd // should not match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")