package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:\b|\.|\s|\!|\?|\n|^)text \(jadad\)(?:\b|\.|\s|\!|\?|\n|$)`)
var str = `lipsum is a dummy text (jadad) alsdasldk. // match
lipsum is a dummy text (jadad). // match
lipsum is a dummy text (jadad) // match
lipsum is a dummy (text (jadad)) // match
lipsum is a dummy text (jadad // should not match
lipsum is a dummy text jadad) // should not match
lipsum is a dummy text (jadad)asd // should not match
lipsum is a dummy ()text (jadad)asdasd // should not match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}