const regex = /(?:\b|\.|\s|\!|\?|\n|^)text \(jadad\)(?:\b|\.|\s|\!|\?|\n|$)/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b|\\.|\\s|\\!|\\?|\\n|^)text \\(jadad\\)(?:\\b|\\.|\\s|\\!|\\?|\\n|$)', 'mgi')
const str = `lipsum is a dummy text (jadad) alsdasldk. // match
lipsum is a dummy text (jadad). // match
lipsum is a dummy text (jadad) // match
lipsum is a dummy (text (jadad)) // match
lipsum is a dummy text (jadad // should not match
lipsum is a dummy text jadad) // should not match
lipsum is a dummy text (jadad)asd // should not match
lipsum is a dummy ()text (jadad)asdasd // should not match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}