package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[^:]+(?::main.*)?$`)
var str = `new jersey
south dakota
virginia:chincoteague
washington:whidbey island
new york:main
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}