$re = '/^[^:]+(?::main.*)?$/mi';
$str = 'new jersey
south dakota
virginia:chincoteague
washington:whidbey island
new york:main
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);