re = /^[^:]+(?::main.*)?$/mi
str = 'new jersey
south dakota
virginia:chincoteague
washington:whidbey island
new york:main
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end