const regex = new RegExp('\\$\\{(.*?)\\}', 'g')
const str = `{
"type" : "id",
"id" : \${idOf('/tar/check/inof/high1')},
"details" : [
{
"name" : "Sanio",
"sig" : "DA123QW"
},
{
"name" : "\${anotherOne}",
"sig" : "BAWE3QW"
},
{
"name" : "Kadek",
"sig" : "KSWE2J"
},
]
},`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}